Get in touch
Back
Resolved

Degraded Performance Affecting Dashboards & Reports

Started 18 Dec at 09:49pm IST.

https://app.nominal.so
Created

Users may experience slow loading times or intermittent unavailability.

Posted 18 Dec at 09:49pm IST.