Get in touch
Back
Resolved

Degraded Performance Affecting Dashboard, Matching and Reports

Started 29 Jan at 04:33pm IST.

https://app.nominal.so
Created

Degraded Performance Affecting Dashboard, Matching and Reports
Users may experience slow loading times or intermittent unavailability.

Posted 29 Jan at 04:33pm IST.